[Resolved] not all images rendering when site viewed on mobile device

In order to post a topic/ticket, you MUST provide content in the main tinyMCE editor field. It is not possible to only use the "Private Content" section, as that input only represents a meta data addition to your ticket. The forum can't save a ticket without actual content!

Whenever you want to post confidential information, such as website addresses, user names, password or anything else you don't want others to see, use the "Private Content" section  that you will find below the main text editor box.

This topic contains 1 reply, has 2 voices, and was last updated by Tekanewa Tekanewa 9 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #25626


    babrewer13
    Participant

    working fine on desktop and laptop device but not in iPhone or iPad – is there a setting tweak I can make? Actual production url posted in private content area.  Thanks in advance for your guidance and support!

    <script type=”text/javascript”>
    jQuery(document).ready(function($){
    $(“#FB_Album_Frame”).FB_Album({
    facebookID: “269567980055938”,
    facebookToken: “754232494724928|k5QkwobBbFNZh6SvPOzuPGEJCcg”,
    responsiveGallery: true,
    responsiveWidth: 90,
    singleAlbumOnly: true,
    singleAlbumID: “272443849768351”,
    maxNumberGalleries: 1,
    maxNumberImages: 0,
    photoShowSocialShare: false,
    paginationLayoutPhotos: false,
    infiniteScrollPhotos: true,
    infiniteScrollPhotosSmart: true,
    albumsFilterAllow: false,
    albumSortControls: false,
    photosFilterAllow: false,
    photoSortControls: false,
    showAlbumDescription: false,
    photoShowClearTape: false,
    maxNumberImages: 50,
    defaultPhotoSortAdded: true,
    albumNameTitle: false,
    defaultPhotoDirectionsASC: false,
    albumNameTitle: false,
    albumNameAbove: false,
    showThumbInfoInPageBar: false,
    showTopPaginationBar: false,
    showBottomPaginationBar: false,
    floatingControlBar: false,
    allowAlbumDescription: false,

    });
    });
    </script>

    Private Content Hidden
  • #25628

    Tekanewa
    Tekanewa
    Keymaster

    Hi,

    the gallery will switch to a dedicated mobile format with forced pagination, in order to prevent the need for excessive scrolling on smaller screens. As such, the behavior is fully intended and can not be changed.

    But because you insisted on setting all controls to be hidden via custom “display: none !important;” rules (see you other ticket), the pagination controls are not showing, even on mobile devices. Instead of using a global rule like that, you might want to think about using CSS media queries that take the screen size into account, in order to at least show the controls on smaller screens:

    Furthermore, your site is creating cross-domain security issues for the icon font used by the gallery, as you are attempting to load files from a different domain than your website:

    Access to Font at ‘https://brewermarketing.worldsecuresystems.com/client-sites/hhsocial/plugins/jquery-facebook-gallery/fonts/fbgallery-icons/fbgallery.woff’ from origin ‘https://www.hiltonheadsocialbakery.com’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘https://www.hiltonheadsocialbakery.com’ is therefore not allowed access.

    As a result, the icon font can not be loaded as your server settings prevent it to do so, which means the gallery can’t display the icons correctly, as the underlying font is missing. You might need to adjust your .htaccess file accordingly, in order to load font files via cross domain:

    https://davidwalsh.name/cdn-fonts

    Tekanewa

Viewing 2 posts - 1 through 2 (of 2 total)

The topic ‘not all images rendering when site viewed on mobile device’ is closed to new replies.