[Resolved] Install errors

In order to post a topic/ticket, you MUST provide content in the main tinyMCE editor field. It is not possible to only use the "Private Content" section, as that input only represents a meta data addition to your ticket. The forum can't save a ticket without actual content!

Whenever you want to post confidential information, such as website addresses, user names, password or anything else you don't want others to see, use the "Private Content" section  that you will find below the main text editor box.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #26085


    weilhalt
    Participant

    The plugin was installed after the second try. The changelog tab says:

    <b>Warning</b>: file_get_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in <b>/var/www/vhosts/web266.c17.hostmaschine.de/tsolms.weilhalt.com/wp-content/plugins/ts-changelog-organizer/assets/ts_clo_settings_changelog.php</b> on line <b>12</b>

    <b>Warning</b>: file_get_contents(https://tsolms.weilhalt.com/wp-content/plugins/ts-changelog-organizer/changelog.txt): failed to open stream: no suitable wrapper could be found in <b>/var/www/vhosts/web266.c17.hostmaschine.de/tsolms.weilhalt.com/wp-content/plugins/ts-changelog-organizer/assets/ts_clo_settings_changelog.php</b> on line <b>12</b>

  • #26086

    Tekanewa
    Tekanewa
    Keymaster

    Hi,

    on your server, a common routine to read in file content via “file_get_contents()” function has been disabled (by setting “allow_url_fopen=0”), which means the plugin can’t read the .txt file that would contain the changelog for the plugin (or any file, for that matter). Instead, your server is returning the warnings instead.

    This is NOT an install error, but solely related to your server setup and has no impact on the overall plugin features (elements), but as long as your server is not allowed to open remote files, you won’t be able to view the changelog from within the plugin. An official changelog can be found here in the forum as well, using the “Changelogs” menu item.

    Tekanewa

  • #26087

    Tekanewa
    Tekanewa
    Keymaster

    I made a quick change to the underlying file that is attempting to read in the changelog file, which is now checking if the “allow_url_fopen” setting is enabled, before reading the file. If it is disabled (like it is on your end), it will instead just provide a link to the official changelog here in the forum.

    Attached, you will find a .zip archive, containing the modified file. Via FTP, simply replace the matching file in the plugin’s “assets” folder on your server, and the warnings should be removed. The change will be made permanent with the next “normal” maintenance update.

    Tekanewa

    Attachments:
    You must be logged in to view attached files.
Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Install errors’ is closed to new replies.